Keyfactor Days 2027 – Participez à la conférence « Trust Security » à San Diego Inscrivez-vous dès maintenant !

Les enregistrements de preuves aident à renouveler les horodatages qui expirent

Keyfactor Keyfactor Technical Team
bouncy castle tech update

Même si nous le souhaitons, les horodatages ne durent pas éternellement. Avec les enregistrements de preuves, il existe un moyen de permettre la non-répudiation à long terme de l'existence des données, même si l'horodatage d'origine expire. 

Les horodatages cryptographiques sont souvent considérés comme éternels. Outre les problèmes liés à l'évolution de la sécurité des algorithmes, qui font qu'ils ne restent pas éternellement sûrs, il y a aussi le problème suivant : lorsque la norme originale du protocole d'horodatage, RFC 3161, a été publiée en 2001, on considérait que l'éternité était de 20 à 30 ans, alors que nous sommes aujourd'hui en 2022. Pour certains, il semble que l'éternité soit arrivée, et pour d'autres, elle n'est plus très loin.

Un enregistrement de preuve est une structure conçue pour permettre la non-répudiation à long terme de l'existence de données, lorsqu'un horodatage doit être significatif longtemps après sa date d'expiration initiale. La structure des enregistrements de preuves, ainsi que la manière de les générer et de les valider, sont décrites dans le RFC 4998, "Evidence Record Syntax (ERS)".

Commencer avec les enregistrements de preuves en Bouncy Castle

Bouncy Castle La version 1.72 prévoit désormais le renouvellement des horodatages dans les enregistrements de preuves ainsi que la mise à jour des algorithmes de hachage. En outre, la prise en charge de documents multiples est disponible, ce qui permet à un groupe de documents, ou même à un groupe de documents groupés, d'être rassemblés sous un seul horodatage via l'utilisation d'une structure d'arbre de Merkle telle que décrite dans le RFC 4998 avec des clarifications supplémentaires décrites dans le RFC 6283.

D'autres travaux sont également prévus sur cette API pour permettre aux développeurs de configurer les algorithmes de hachage acceptables et les dates d'expiration à spécifier. N'hésitez pas à nous faire part de vos commentaires sur les API étendues. Publiez vos commentaires sur GitHub Discussions.

L'API ERS est fournie dans le jar bcpkix et peut être trouvée dans le paquet org.bouncycastle.tsp.ers. Des exemples d'utilisation pour des documents uniques et multiples sont disponibles dans org.bouncycastle.tsp.test.ERSTest.

Pour plus d'informations

Vous trouverez ici plus d'informations pour commencer :

S'abonner à La Source

Stay secure with Keyfactor's monthly newsletter, packed with expert insights and practical steps for quantum-readiness.

Lire la suite

Keyfactor Command Release
Produit

Vers l'avenir post-quantique avec Keyfactor Command 25.1

En savoir plus
Produit

Keyfactor Symmera s'associe à Symmera pour offrir une sécurité simple pour l'IIoT et l'OT

En savoir plus
Signserver tech update
Communauté des développeurs

Sécuriser OpenPGP et les paquets Debian avec la signature de code

En savoir plus